当前位置:首页 > 问答

圆弧指标公式源码

我来帮TA回答

求圆弧所有计算公式

弧长的计算公式
弧长公式:弧长=θ*r
,θ是角度
r是半径
l=nπr÷180
在半径是R的圆中,因为360°的圆心角所对的弧长就等于圆周长C=2πR,所以n°圆心角所对的弧长为l=nπR÷180。
例:半径为1cm,45°的圆心角所对的弧长为
l=nπR÷180
=45×派×1÷180
约等于0.785(cm)
如果已知他的沿圆锥体的一条母线和侧面与下底面圆的交线将圆锥体剪开铺平,就得到圆锥的平面展开图。它是由一个半径为圆锥体的母线长,弧长等于圆锥体底面圆的周长的扇形和一个圆组成的,这个扇形又叫圆锥的侧面展开图。
补充公式:S扇=nπR^2/360
=πRnR/360
=2πRn/360×1/2R
=πRn/180×1/2R
所以:l=2S/R

求周线圆弧底选股公式(有点高难度哦)

去下载Java通用版(如果你手机不支持Java安装,那你别有这个念头了)
http://m.gw.com.cn/2.51/b/gwm.jar
如果你是ppc的wm系统。
建议去找wm系统的。

短线高手主力版“买卖趋势”指标公式源码

非常准的趋势买卖(图片演示在下面网址里)

VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,'B'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,'S'),COLORGREEN;

绿上卖,红下买。

谁有通达信的济安线指标公式源代码

[通达信] 通达信济安线主图源码公式:
通达信济安线主图源码公式
AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,N))/MA(CLOSE,N);
济安线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORMAGENTA;
CC:=(CLOSE/济安线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-济安线)/济安线)/3;
TMP:=MA1-MAAA*MA1;
J:IF(TMP<=济安线,济安线,DRAWNULL),LINETHICK3,COLORCYAN;
A:TMP,LINETHICK2,COLORYELLOW;
X:IF(TMP<=济安线,TMP,DRAWNULL),LINETHICK2,COLORGREEN

求助通达信圆弧底公式

AA:=(C*2+H+L+O)/5;
A0:=MA(C,5);
A1:(EMA(AA,4)+MA(AA,8)+MA(AA,16))/3,COLORWHITE;
A2:(EMA(AA,9)+MA(AA,18)+MA(AA,36))/3,COLORFF00FF;
A3:(EMA(AA,13)+MA(AA,26)+MA(AA,52))/3,COLOR00FF00;
A4:(EMA(AA,24)+MA(AA,48)+MA(AA,96))/3,COLOR0000FF;
A5:=EMA(100*(C-LLV(L,100))/(HHV(H,100)-LLV(L,100)),5);
A6:=A5/4;
A7:=MAX(MAX(A1,A2),MAX(A3,A4));
A8:=MIN(MIN(A1,A2),MIN(A3,A4));
A9:=MIN(MIN(A1,A2),A3);
A10:=MAX(MAX(A1,A2),A3);
DRAWICON(A6>22.5 AND REF(A0,1)>REF(A0,2)AND A0<REF(A0,1),H+0.2,2);
DRAWICON(CROSS(A2,A4)AND A3>REF(A3,1)AND A0>REF(A0,2)AND (A1-A4)/A4<0.02,A2,1);
DRAWICON(CROSS(A1,A4)AND CROSS(A2,A3),A1,10);
DRAWTEXT(FILTER(H>A7 AND L<A8 AND A1>REF(A1,1)AND A2>REF(A2,1)AND A4>REF(A4,2)AND (A7-A8)/A8<0.04 AND C>O AND (H-C)/(C-O)<0.4,3),A4-0.1,'穿四线');
DRAWTEXT(LONGCROSS(A1,A3,30)AND (A4-A3)/A3<0.05 AND A10<A4,A1*0.98,'圆弧底');
DRAWTEXT(LONGCROSS(A1,A2,15)AND CROSS(A2,A3),A1*0.97,'双交叉');
DRAWTEXT((A1-A2)/A2>0.04 AND A2>A3 AND L>A1 AND O>C AND O=H,H+0.1,'顶');
DRAWTEXT(FILTER(A4>REF(A4,2)AND REF(A1,3)<REF(A3,3)AND C>O AND(A10-A9)/A9<0.005,5),A8-0.05,'三线粘合'),COLORRED;

求个圆弧底选股公式

给你一个在“百度知道”里搜到的现成的答案:
AA:=(C*2+H+L+O)/5;
A1:=(EMA(AA,4)+MA(AA,8)+MA(AA,16))/3;
A2:=(EMA(AA,9)+MA(AA,18)+MA(AA,36))/3;
A3:=(EMA(AA,13)+MA(AA,26)+MA(AA,52))/3;
A4:=(EMA(AA,24)+MA(AA,48)+MA(AA,96))/3;
A10:=MAX(MAX(A1,A2),A3);
圆弧底:LONGCROSS(A1,A3,30) AND (A4-A3)/A3<0.05 AND A10<A4;